Back to overview
Degraded

EU Service Degraded

Jan 19 at 03:40pm UTC
Affected services
EU

Resolved
Jan 19 at 04:40pm UTC

Service in the EU has now normalised. We apologise for the inconvenience this caused.

Created
Jan 19 at 03:40pm UTC

At 17:40 EET, service in the EU is degraded for a small percentage of customers. Our technical teams are actively working to restore normal service.