Back to overview
Degraded
US service impacted by AWS incident
Oct 20 at 03:03pm UTC
Affected services
US
US Enterprise
US
US Enterprise
Resolved
Oct 20 at 06:29pm UTC
The AWS incident appears to be resolved. US service functionality has been restored and all clients should once again be able to work as normal.
Affected services
Created
Oct 20 at 03:03pm UTC
We’re currently experiencing known issues affecting the platform due to the global Amazon Web Services earlier outage. We sincerely apologise for any inconvenience this may be causing. Our technical team is actively working with their technicians to resolve the issue as quickly as possible.
Affected services