Back to overview
Downtime
EU service down
Oct 15 at 08:26am UTC
Affected services
EU
Resolved
Oct 15 at 08:52am UTC
Eu service has been restored and all clients should be able to continue work as normal
Affected services
Updated
Oct 15 at 08:39am UTC
Some services have been restored, some clients are still blocked to be logged in as the service normalizes
Affected services
Created
Oct 15 at 08:26am UTC
Service in EU is down our technicians are actively working to resolve the issue as quickly as possible, issue seems to relate to the issues last days. We apologize for the inconvenience.
Affected services