Back to overview
Downtime
Eu service down
Oct 14 at 01:32pm UTC
Affected services
EU
Resolved
Oct 14 at 01:52pm UTC
Eu service downtime has been resolved.
Our technicians are actively working to investigate the root cause and creating a permanent fix. We apologize for the inconvenience this caused.
Affected services
Updated
Oct 14 at 01:43pm UTC
Service in EU is down our technicians are actively working to resolve the issue as quickly as possible. At the moment some users are blocked from logging in as the service is normalising.
Affected services
Created
Oct 14 at 01:32pm UTC
Service in EU is down our technicians are actively working to resolve the issue as quickly as possible. We apologize for the inconvenience.
Affected services