Back to overview
Downtime

Eu service down

Oct 13 at 08:23am UTC
Affected services
EU

Resolved
Oct 13 at 09:01am UTC

EU Database and service up and running as normal, We apologize for the inconvenience.

Created
Oct 13 at 08:23am UTC

Service in EU is down our technicians are actively working to resolve the issue as quickly as possible. We apologize for the inconvenience.