Back to overview
Downtime
Provet Pay Downtime
Feb 07 at 10:09am UTC
Affected services
Payment service
Resolved
Apr 16 at 11:00am UTC
Incident report: https://cloud.nordhealth.com/index.php/s/Gf3GJ94C3BSHSfn
Affected services
Payment service
Updated
Feb 07 at 10:28am UTC
Provet Pay issue has now been resolved. Thank you for your patience
Affected services
Payment service
Created
Feb 07 at 10:09am UTC
Error 500 affecting all Provet Pay transactions.
Affected services
Payment service