Back to overview
Degraded

Provet Pay payouts suspended for certain customers

Jan 16 at 06:53pm UTC
Affected services
Payment service

Resolved
Jan 20 at 08:02pm UTC

The payout delay for payouts expected on 16th & 17th January (which would be for 15th & 16th) has been as a result a configuration issue with Provet Pay payout logic. Due to the error the payouts had been initiated at a slower regular bank transfer which usually takes few business days to complete. We've restored the normal priority payout schedule Friday morning (on January 17th) and normal payouts resumed from then onwards, arriving by the next business day as usual.

The payouts for January 16th should arrive to you on Tuesday January 21st and the payouts for 17th should arrive with you Wednesday January 22nd

Today you should receive payout for Friday-Sunday sales.

Wednesday onwards you should be receive the previous days sales payouts normally.

Created
Jan 16 at 06:53pm UTC

Effective from the end of December 2024, Adyen, who is the payment provider in cooperation with Provet Pay has suspended Provet Pay payouts to certain customers pending updated KYC verification via the Provet Pay Management Page.