Back to overview
Degraded

Insurance claim failures with Agria integration

Jun 1, 2026 at 7:50am UTC
Affected services
Insurance integrations

Resolved
Jun 2, 2026 at 1:31pm UTC

The integration is stabilising again. We keep monitoring the situation together with our partner to confirm full resolution.

The issue affected Agria Finland too, as Agria made the decision to close direct claim handling to mitigate further issues. The claim handling is now open in all countries again.

Updated
Jun 2, 2026 at 8:57am UTC

We are noticing more issues with the integration, we are monitoring the situation. Agria is actively investigating the matter on their end, and has escalated it to an active incident.

Updated
Jun 1, 2026 at 2:47pm UTC

We have received confirmation from the partner that the cause of the issue has been resolved, and we are now monitoring the situation to confirm stability.

Updated
Jun 1, 2026 at 12:30pm UTC

We are noticing more issues with the integration, we are monitoring the situation and we are in contact with our partner to resolve the issue as soon as possible.

Updated
Jun 1, 2026 at 10:19am UTC

Insurance claim submissions to Agria are processing normally again following a period of intermittent failures affecting mainly Sweden and Norway; any claims that failed during this window can be resubmitted.

Created
Jun 1, 2026 at 7:50am UTC

We're seeing failures when submitting insurance claims to Agria, affecting customers in Sweden and Norway. We've noticed issues in how requests to the Agria integration are currently being handled, and are working with our partner to resolve them. Early signs suggest the connection may be starting to recover, and we'll post an update once it's stable.