Back to overview
Degraded
Slowness in EU
May 29, 2026 at 9:34am UTC
Affected services
EU
Resolved
May 29, 2026 at 10:56am UTC
We have identified a plausible root cause and have mitigated the slowness for the time being. We are continuing to monitor the situation closely, but services in the EU region should now be returning to normal.
Affected services
Created
May 29, 2026 at 9:34am UTC
We are aware of platform slowness for some customers.
Our engineering team is actively investigating and working on a resolution.
We apologise for the inconvenience and will provide updates as they become available.
Affected services