Platform slowness for some customers
Resolved
May 28, 2026 at 12:43pm UTC
System load has now re-normalised, and system performance has been restored. We apologise for any inconvenience caused
Affected services
Updated
May 28, 2026 at 12:36pm UTC
We've identified the cause of the issue and our mitigation efforts have started to have an impact. System load is re-normalising, and performance should start improving
Affected services
Created
May 28, 2026 at 11:07am UTC
We are aware of an issue causing platform slowness for some customers.
Our engineering team is actively investigating and working to resolve this as quickly as possible.
We apologise for the inconvenience and will provide updates as they become available.
Affected services