Back to overview
Degraded

Issues with admission and starting consultations

May 27, 2026 at 5:05am UTC
Affected services
EU
US

Resolved
May 27, 2026 at 5:34am UTC

We have identified the issue, and a fix has now been implemented.

We apologize for the inconvenience this has caused and appreciate your patience while we worked to resolve it.

Created
May 27, 2026 at 5:05am UTC

We are aware of an issue affecting Admit and consultation start workflows. Our engineers are currently investigating and working to resolve it as quickly as possible. We apologize for the inconvenience this is causing.