Back to overview
Downtime

Service critically degraded

May 15, 2026 at 8:52am UTC
Affected services
EU
Pegasus

Resolved
May 15, 2026 at 9:55am UTC

The service is now fully restored.

We apologise for the inconvenience this caused.

We will investigate the incident thoroughly and share a post-mortem once completed.

Updated
May 15, 2026 at 9:49am UTC

EU is still normalising, we expect the service to be completely resolved in the coming minutes.

Updated
May 15, 2026 at 9:32am UTC

Pegasus should now have normalised.

We are currently rolling back to previous stable version the issue should be resolved within the next 5 -15 minutes

Updated
May 15, 2026 at 9:28am UTC

We are currently rolling back to previous stable version the issue should be resolved within the next 5 -15 minutes

Updated
May 15, 2026 at 9:27am UTC

Service is slowly coming back online.

Service degraded in some of the environments, we are aware that some services seem as well to be down.

We are aware and working on a solution as soon as possible.

Created
May 15, 2026 at 8:52am UTC

Service critically degraded in some of the environments, we are aware that some services seem as well to be down. We are aware and working on a solution as soon as possible.