Back to overview
Degraded

Multiple UI Defects Impacting User Experience

May 7, 2026 at 10:47am UTC
Affected services
EU
Enterprise
US
US Enterprise
Pegasus
Darwin

Resolved
May 7, 2026 at 3:38pm UTC

The release containing all major UI fixes for Provet Cloud has now been deployed to production across all environments.

We will continue resolving smaller UI issues over the coming days, but for now this incident is considered resolved.

We apologize for the inconvenience this caused and appreciate your patience while the issues were being addressed.

Updated
May 7, 2026 at 2:55pm UTC

The deployment of release 20260507.120540, which contains most major UI issue fixes for Provet Cloud, is soon underway across all affected environments.

Updated
May 7, 2026 at 12:02pm UTC

Multiple fixes are currently underway, and we are releasing them progressively as they are completed and QA approved. We are prioritizing deployments to restore UI stability as quickly as possible.

Created
May 7, 2026 at 10:47am UTC

We are aware of multiple reports of visual errors creating a degradation of functionality across the platform. Our team is currently working on a fix and we will keep you updated. We apologise for any inconvenience