Back to overview
Degraded

Global notifications causing issue in UI for fields and buttons

Apr 29, 2026 at 11:20am UTC
Affected services
EU
Enterprise
US
US Enterprise
Pegasus
Darwin

Resolved
Apr 29, 2026 at 5:20pm UTC

The issue has now been resolved across all environments.

Thank you for your patience, and we apologize for the inconvenience this caused.

Updated
Apr 29, 2026 at 4:15pm UTC

Fix and release is being slowly rolled out.

As a workaround if you encounter non clickable button or fields not responding , refresh the page, while the fix is being rolled out to all environments.

Updated
Apr 29, 2026 at 2:45pm UTC

Fix deployment is taking a bit longer than usual.

Apologies still for the inconvenience as we try to get this issue sorted.

Updated
Apr 29, 2026 at 12:27pm UTC

A fix has been identified for the issue causing hidden notification elements to block user interaction across multiple App services.

The estimated time for full resolution is approximately within the next 2 hours.

Created
Apr 29, 2026 at 11:20am UTC

Dismissing notifications does not properly remove the notification element from the DOM. As a result, the hidden element remains layered above page content, causing z-index conflicts. This blocks user interaction with underlying buttons and input fields, rendering parts of the page non-interactable.

As a workaround if you encounter non clickable button or fields not responding , refresh the page.

Our engineers are working on a solution. Apologise for the inconvenience