Agria insurance claim responses not updating in Provet
Resolved
Apr 28, 2026 at 12:15pm UTC
The cleanup of all affected claims is now complete, and the issue is fully resolved.
We apologise for any inconvenience this may have caused.
Affected services
Updated
Apr 28, 2026 at 7:54am UTC
Yesterday evening, the fix was successfully released to production. We immediately saw an improvement, and the core issue is officially resolved.
We are already recovering the data for processed claims, and we'll share an update once the situation is completely resolved.
Affected services
Updated
Apr 27, 2026 at 12:32pm UTC
We have been able to verify that the issue has been resolved. We are now working on fetching the missing information for processed claims in Provet.
Affected services
Updated
Apr 27, 2026 at 10:40am UTC
The fix has been released to the production environment, and we are monitoring our systems to confirm that the original issue has been fully resolved.
Once confirmed, we will proceed to recover the pending data and update all stuck claims in Provet.
Affected services
Updated
Apr 27, 2026 at 9:45am UTC
A fix for the issue will be released shortly. The engineering team is also exploring options to recover the claim status already submitted, and display it in Provet correctly.
We will share an update as soon as the fix is released.
Affected services
Created
Apr 27, 2026 at 8:08am UTC
We are aware of an issue affecting Agria insurance claim processing. Claims submitted from Provet to Agria are being sent successfully, but the responses from Agria are not being received back into the system. This means clinics may not see updated claim statuses or compensation details on their invoices.
The issue primarily affects clinics in Finland, though we are still confirming the full scope. Claims processed by Agria since approximately 07:17 EET / 06:17 CET today (April 27th) may be affected.
Our engineering team has identified the root cause and a fix is being implemented.
Affected services