Back to overview
Degraded
Service disruption in processing direct compensations for If, OP Pohjola, and LähiTapiola.
Mar 27, 2026 at 07:48am UTC
Affected services
Insurance integrations
Resolved
Mar 27, 2026 at 07:50am UTC
Service is back to normal operation.
We’re sorry for the inconvenience caused and thank you for your patience.
Affected services
Created
Mar 27, 2026 at 07:48am UTC
We’re currently investigating an issue processing direct compensations for If, OP Pohjola, and LähiTapiola.
We apologise for the disruption this is causing, we’re continuing to investigate as our highest priority.
Affected services