Back to overview
Degraded

EU service degraded

Feb 05 at 07:20am UTC
Affected services
EU

Resolved
Feb 05 at 08:00am UTC

We have identified the root cause and the service should now be normalising again. Apologies for the inconvenience this caused.

Created
Feb 05 at 07:20am UTC

We have noticed a slowness that started about 07:00 UTC for EU environment. Our engineers are actively investigating for a quick solution. Apologies for any inconvenience.