Back to overview
Downtime
PACS not available
Aug 11 at 06:59am UTC
Affected services
PACS service
Resolved
Aug 11 at 07:59am UTC
Issue has now been resolved.
Affected services
Created
Aug 11 at 06:59am UTC
PACS available via provet.fi cannot be reached. Our engineers are actively working to resolve the issue, apologise for the inconvenience.
Affected services