Back to overview
Degraded
Reports Not Loading, EU
Jul 24 at 09:45am UTC
Affected services
EU
Resolved
Jul 24 at 11:53am UTC
Issue has been identified and reports generation should now be normalising and working again.
Affected services
Created
Jul 24 at 09:45am UTC
We are currently experiencing an issue where reports within the system are not loading as expected within EU environment. Users attempting to generate or access reports may encounter prolonged loading times, and in many cases, the process results in a timeout error. Thank you for your patience as we work to restore normal functionality.
Affected services