Cusomers unable to finalise invoices.
Resolved
Jul 02 at 09:46pm UTC
The problem identified during invoice finalization has now been resolved, and the system has returned to full functionality. The fix was deployed 2nd of July to all environment at 23:46 CEST latest. We apologize for any inconvenience caused.
Affected services
US
EU
Enterprise
US Enterprise
Updated
Jul 02 at 04:24pm UTC
We're currently completing the final build steps to fix this issue. After that, we'll run our thorough tests. Once testing is complete, we'll begin the production deployment. Thank you for your continued patience.
Affected services
US
EU
Enterprise
US Enterprise
Updated
Jul 02 at 11:37am UTC
The team are still working hard to fix the issue. Thank you for your patience!
Affected services
US
EU
Enterprise
US Enterprise
Updated
Jul 02 at 09:14am UTC
Cause identified and working on fix.
Affected services
US
EU
Enterprise
US Enterprise
Created
Jul 02 at 08:57am UTC
We're working hard to fix the issue and we will provide an update as soon as possible.
Affected services
US
EU
Enterprise
US Enterprise