Back to overview
Degraded

Provet Pay Degraded

Apr 21 at 06:01pm UTC
Affected services
Payment service

Resolved
Apr 21 at 06:33pm UTC

Issue has been resolved.

More info at https://status.adyen.com/incident-history#2025

Updated
Apr 21 at 06:06pm UTC

Service is normalising.

Payment processing in EU has fully recovered since 19:39 CET. Some degradation might be still experienced

Created
Apr 21 at 06:01pm UTC

We have identified an ongoing incident affecting payment services via Adyen, starting at 19:09 CEST. This issue is currently impacting Provet Pay payment processing..

As this issue originates on Adyen's side, we are unable to take direct action at this time. However, we are actively monitoring the situation and will provide updates as they become available.

For the latest status, please refer to https://status.adyen.com/