Resolved
This issue has been resolved. Payment processing is returned to normal operations.
Monitoring
Fix is in production and we're seeing a recovery of the processing throughput
Identified
A recent change in telemetry effectively reduced concurrency by a factor of 10. A fix is being prepared and we'll update accordingly.
Investigating
Some payment transactions may be delayed or failing. Our team is investigating and working to restore full service. We will provide updates as more information becomes available.