Resolved
A fix was released to Production environments of InvoiceXpress.
Identified
The issue has been identified, InvoiceXpress is mitigating and service should be restored momentarily
Identified
Customer affected will not able to finalise invoices.