Resolved
Full service has now been restored for the US environment and system performance is back to normal.
Monitoring
We have restored the service, and the US environment is now stable. We are still waiting for additional information from our upstream service provider, as well as a permanent fix to prevent this from happening again.
Identified
The US environment continues to experience degraded performance. While service has recovered for some customers, others may still experience significant slowness.
Our investigation indicates that the issue appears to originate with an upstream service provider.
We are actively monitoring the situation and working with the provider to restore full service as quickly as possible.
Investigating
The US environment experienced degraded performance. Service is already returning to normal for some, although some customers may still experience slowness while the environment continues to stabilize. We are still investigating.